summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2010-04-19 11:59:09 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-05-07 16:38:23 -0400
commitfc7ec12f1b851bab1eedf3ecdcb094ea80b46dd2 (patch)
tree9aa674b262b92ebe2f66c745a42f6cec4a0a1c18 /src/Makefile.am
parentca6aa84e20e445fb04dfce416a8c3a1912b26451 (diff)
downloadsssd-fc7ec12f1b851bab1eedf3ecdcb094ea80b46dd2.tar.gz
sssd-fc7ec12f1b851bab1eedf3ecdcb094ea80b46dd2.tar.xz
sssd-fc7ec12f1b851bab1eedf3ecdcb094ea80b46dd2.zip
Add support for delayed kinit if offline
If the configuration option krb5_store_password_if_offline is set to true and the backend is offline the plain text user password is stored and used to request a TGT if the backend becomes online. If available the Linux kernel key retention service is used.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5fb406234..5ae5b2e62 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -767,6 +767,7 @@ libsss_krb5_la_SOURCES = \
providers/child_common.c \
providers/krb5/krb5_utils.c \
providers/krb5/krb5_become_user.c \
+ providers/krb5/krb5_delayed_online_authentication.c \
providers/krb5/krb5_auth.c \
providers/krb5/krb5_common.c \
providers/krb5/krb5_init.c \
@@ -776,6 +777,7 @@ libsss_krb5_la_CFLAGS = \
$(DHASH_CFLAGS)
libsss_krb5_la_LIBADD = \
$(DHASH_LIBS) \
+ $(KEYUITLS_LIB) \
$(KRB5_LIBS)
libsss_krb5_la_LDFLAGS = \
-version-info 1:0:0 \
@@ -806,6 +808,7 @@ libsss_ipa_la_SOURCES = \
util/find_uid.c \
providers/krb5/krb5_utils.c \
providers/krb5/krb5_become_user.c \
+ providers/krb5/krb5_delayed_online_authentication.c \
providers/krb5/krb5_common.c \
providers/krb5/krb5_auth.c
libsss_ipa_la_CFLAGS = \
@@ -816,6 +819,7 @@ libsss_ipa_la_CFLAGS = \
libsss_ipa_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
+ $(KEYUTILS_LIBS) \
$(KRB5_LIBS)
libsss_ipa_la_LDFLAGS = \
-version-info 1:0:0 \