summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-05-22 17:35:48 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-05-23 12:15:59 -0400
commitce145e54b99b8356c21d58d0806e038f8f6d7afb (patch)
treecbaf0678817d62845618b0fcd41f351aaf95da34 /src/Makefile.am
parente50a12867489c0889a4f17654e401ddddbc283bb (diff)
downloadsssd-ce145e54b99b8356c21d58d0806e038f8f6d7afb.tar.gz
sssd-ce145e54b99b8356c21d58d0806e038f8f6d7afb.tar.xz
sssd-ce145e54b99b8356c21d58d0806e038f8f6d7afb.zip
Proxy provider PAM handling in child process
This patch adds a new tevent_req to the proxy provider, which will spawn short-lived child processes to handle PAM requests. These processes then call the proxied PAM stack and return the results via SBUS method reply. Once it is returned, the parent process kills the child. There is a maximum of ten child processes running simultaneously, after which requests will be queued for sending once a child slot frees up. The maximum processes will be made configurable at a later date (as this would violate string freeze).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cb0685cd7..b83523255 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -62,7 +62,8 @@ sssdlibexec_PROGRAMS = \
krb5_child \
ldap_child \
$(sssd_pk) \
- $(sssd_info)
+ $(sssd_info) \
+ proxy_child
dist_sssdlibexec_SCRIPTS = \
config/upgrade_config.py
@@ -356,6 +357,7 @@ dist_noinst_HEADERS = \
providers/ipa/ipa_timerules.h \
providers/ipa/ipa_auth.h \
providers/ipa/ipa_dyndns.h \
+ providers/proxy/proxy.h \
tools/tools_util.h \
tools/sss_sync_ops.h \
resolv/async_resolv.h \
@@ -753,7 +755,7 @@ libsss_ldap_la_LDFLAGS = \
-module
libsss_proxy_la_SOURCES = \
- providers/proxy.c
+ providers/proxy/proxy.c
libsss_proxy_la_CFLAGS = \
$(AM_CFLAGS)
libsss_proxy_la_LIBADD = \
@@ -870,6 +872,16 @@ ldap_child_LDADD = \
$(OPENLDAP_LIBS) \
$(KRB5_LIBS)
+proxy_child_SOURCES = \
+ $(SSSD_UTIL_OBJ) \
+ providers/proxy/proxy_child.c
+proxy_child_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(POPT_CFLAGS)
+proxy_child_LDADD = \
+ $(PAM_LIBS) \
+ $(SSSD_LIBS)
+
memberof_la_SOURCES = \
ldb_modules/memberof.c
memberof_la_CFLAGS = \