summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2010-04-15 18:26:18 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-04-26 09:55:10 -0400
commit25026f0f0e7bdab056a8608c47b3ed163cacadbf (patch)
treeeb772ba6f6d90e154228d15574d64f40f8cba233 /src/Makefile.am
parente3b1ebdf59b44efd1a8a8c4632ee0c8166da94a5 (diff)
downloadsssd-25026f0f0e7bdab056a8608c47b3ed163cacadbf.tar.gz
sssd-25026f0f0e7bdab056a8608c47b3ed163cacadbf.tar.xz
sssd-25026f0f0e7bdab056a8608c47b3ed163cacadbf.zip
Make the handling of fd events opaque
Depending on the version of the OpenLDAP libraries we use two different schemes to find the file descriptor of the connection to the LDAP server. This patch removes the related ifdefs from the main code and introduces helper functions which can handle the specific cases.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e56d7b166..92244f4a4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -722,6 +722,7 @@ libsss_ldap_la_SOURCES = \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
providers/ldap/sdap_child_helpers.c \
+ providers/ldap/sdap_fd_events.c \
providers/ldap/sdap.c \
util/user_info_msg.c \
util/sss_ldap.c \
@@ -793,6 +794,7 @@ libsss_ipa_la_SOURCES = \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
providers/ldap/sdap_child_helpers.c \
+ providers/ldap/sdap_fd_events.c \
providers/ldap/sdap.c \
util/user_info_msg.c \
util/sss_ldap.c \