summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-05-06 10:09:41 -0400
committerStephen Gallagher <sgallagh@redhat.com>2010-05-16 13:28:43 -0400
commitfa26de3b1a8993a1c5a4b071851e5e5ff7ec2ce6 (patch)
tree7ce1399b2df00674a166ab1d6e387368667a6c70 /src/Makefile.am
parent67421f2d62ceffb070070245a436bc46252b9420 (diff)
downloadsssd-fa26de3b1a8993a1c5a4b071851e5e5ff7ec2ce6.tar.gz
sssd-fa26de3b1a8993a1c5a4b071851e5e5ff7ec2ce6.tar.xz
sssd-fa26de3b1a8993a1c5a4b071851e5e5ff7ec2ce6.zip
Add ldap_access_filter option
This option (applicable to access_provider=ldap) allows the admin to set an additional LDAP search filter that must match in order for a user to be granted access to the system. Common examples for this would be limiting access to users by in a particular group, for example: ldap_access_filter = memberOf=cn=access_group,ou=Groups,dc=example,dc=com
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5c428e74f..530ccfe02 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -343,6 +343,7 @@ dist_noinst_HEADERS = \
providers/krb5/krb5_utils.h \
providers/ldap/ldap_common.h \
providers/ldap/sdap.h \
+ providers/ldap/sdap_access.h \
providers/ldap/sdap_async.h \
providers/ldap/sdap_async_private.h \
providers/ipa/ipa_common.h \
@@ -720,6 +721,7 @@ libsss_ldap_la_SOURCES = \
providers/ldap/ldap_id.c \
providers/ldap/ldap_id_enum.c \
providers/ldap/ldap_id_cleanup.c \
+ providers/ldap/sdap_access.c \
providers/ldap/ldap_auth.c \
providers/ldap/ldap_init.c \
providers/ldap/ldap_common.c \