summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-03-10 10:47:26 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-03-12 09:00:28 -0500
commitb1798ddcfb952efb7cc8bacaf51b3486a7fec121 (patch)
tree31ee1eccee1247c0c71f66fb99ce83b5f83021ac /src/Makefile.am
parent03e7e62d439a2ef21f3c1c074a593a15606a0e1e (diff)
downloadsssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.tar.gz
sssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.tar.xz
sssd-b1798ddcfb952efb7cc8bacaf51b3486a7fec121.zip
Fix build when check-devel is not installed
tests/common.c is now required by all tests (check-based and not), so we need to properly ifdef it
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9da383b5d..4bedaa9ef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -453,15 +453,15 @@ sss_groupshow_LDADD = \
#################
# Feature Tests #
#################
-if HAVE_CHECK
noinst_LTLIBRARIES += \
libsss_test_common.la
libsss_test_common_la_SOURCES = \
tests/common.c
-libsss_test_common_la_LIBADD = \
- $(SSSD_LIBS) \
- $(CHECK_LIBS)
+
+if HAVE_CHECK
+libsss_test_common_la_SOURCES += \
+ tests/common_check.c
sysdb_tests_DEPENDENCIES = \
$(ldblib_LTLIBRARIES)