summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-03-30 15:26:58 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-04-08 08:53:35 -0400
commit9c124af8868a7d3908c03ec369e28daef17d5f12 (patch)
tree2efdddd72acb1d48941c2ee9749c6ad7cadb8697 /src/Makefile.am
parent81020661d35772b5499525b76a19c9a3794c953e (diff)
downloadsssd-9c124af8868a7d3908c03ec369e28daef17d5f12.tar.gz
sssd-9c124af8868a7d3908c03ec369e28daef17d5f12.tar.xz
sssd-9c124af8868a7d3908c03ec369e28daef17d5f12.zip
SELinux login management
Adds a new option -Z to sss_useradd and sss_usermod. This option allows user to specify the SELinux login context for the user. On deleting the user with sss_userdel, the login mapping is deleted, so subsequent adding of the same user would result in the default login context unless -Z is specified again. MLS security is not supported as of this patch.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e5c12df8c..e56d7b166 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -295,6 +295,9 @@ TOOLS_LIBS = \
if BUILD_SELINUX
TOOLS_LIBS += $(SELINUX_LIBS)
endif
+if BUILD_SEMANAGE
+ TOOLS_LIBS += $(SEMANAGE_LIBS)
+endif
dist_noinst_HEADERS = \
monitor/monitor.h \
@@ -529,11 +532,15 @@ FILES_TESTS_LIBS = \
if BUILD_SELINUX
FILES_TESTS_LIBS += $(SELINUX_LIBS)
endif
+if BUILD_SEMANAGE
+ FILES_TESTS_LIBS += $(SEMANAGE_LIBS)
+endif
files_tests_SOURCES = \
$(SSSD_DEBUG_OBJ) \
tests/files-tests.c \
util/check_and_open.c \
+ tools/selinux.c \
tools/files.c
files_tests_CFLAGS = \
$(AM_CFLAGS) \