summaryrefslogtreecommitdiffstats
path: root/server/configure.ac
diff options
context:
space:
mode:
authorGeorge McCollister <georgem@novatech-llc.com>2010-02-04 11:07:34 -0600
committerStephen Gallagher <sgallagh@redhat.com>2010-02-05 09:43:42 -0500
commit63be61852bd7ad1f74569843fb90629d63adb591 (patch)
tree04ef03c32be11507365d3c348cf28fb2d8ac3531 /server/configure.ac
parentd61d37ed5c7cc51f1106fe3105c3cf226cc10277 (diff)
downloadsssd-63be61852bd7ad1f74569843fb90629d63adb591.tar.gz
sssd-63be61852bd7ad1f74569843fb90629d63adb591.tar.xz
sssd-63be61852bd7ad1f74569843fb90629d63adb591.zip
Added option to use libcrypto instead of NSS.
crypto_sha512crypt.c is a clone of nss_sha512crypt.c with the exception that all usage of NSS and related libraries has been switched to libcrypto. I renamed nss_sha512crypt.h to sha512crypt.h since it is common to both crypto_sha512crypt.c and nss_sha512crypt.c. Note that the random number generator is not seeded manually and thus relies on seeding done automatically by libcrypto. On some systems without /dev/urandom seeding may not be performed. See http://www.openssl.org/docs/crypto/RAND_add.html. Signed-off-by: George McCollister <georgem@novatech-llc.com>
Diffstat (limited to 'server/configure.ac')
-rw-r--r--server/configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/server/configure.ac b/server/configure.ac
index 1e414a309..47d537834 100644
--- a/server/configure.ac
+++ b/server/configure.ac
@@ -77,6 +77,7 @@ m4_include([external/docbook.m4])
m4_include([external/sizes.m4])
m4_include([external/python.m4])
m4_include([external/selinux.m4])
+m4_include([external/crypto.m4])
m4_include([util/signal.m4])
PKG_CHECK_MODULES([DBUS],[dbus-1])
@@ -95,8 +96,6 @@ if test x$has_dbus != xno; then
LDFLAGS="$SAFE_LDFLAGS"
fi
-PKG_CHECK_MODULES([NSS],[nss])
-
if test x$HAVE_MANPAGES != x; then
CHECK_XML_TOOLS
CHECK_STYLESHEET([$SGML_CATALOG_FILES],