summaryrefslogtreecommitdiffstats
path: root/server/configure.ac
diff options
context:
space:
mode:
authorsbose <sbose@sles10.site>2009-09-09 12:26:07 +0200
committerStephen Gallagher <sgallagh@redhat.com>2009-09-24 21:36:59 -0400
commit7716bef4a7515344a7f552011ba458aaf4582e44 (patch)
treec15f12b8c1e8f19fba47c8b9f1988fc2d9302432 /server/configure.ac
parent794c66c7b1f8a367b26b8f56c8503007c234333e (diff)
downloadsssd-7716bef4a7515344a7f552011ba458aaf4582e44.tar.gz
sssd-7716bef4a7515344a7f552011ba458aaf4582e44.tar.xz
sssd-7716bef4a7515344a7f552011ba458aaf4582e44.zip
added support for older MIT kerberos versions
- make the build of the locator plugin optional - added a man page for the locator plugin - use krb5.h if krb5/krb5.h cannot be found - added alternatives for missing functions - set -DDBUS_API_SUBJECT_TO_CHANGE if libdbus version is lesser than 1.0.0
Diffstat (limited to 'server/configure.ac')
-rw-r--r--server/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/server/configure.ac b/server/configure.ac
index 475bdca6a..03d2885ac 100644
--- a/server/configure.ac
+++ b/server/configure.ac
@@ -67,6 +67,12 @@ m4_include([external/python.m4])
m4_include([util/signal.m4])
PKG_CHECK_MODULES([DBUS],[dbus-1])
+dnl if test -n "`$PKG_CONFIG --modversion dbus-1 | grep '^0\.'`" ; then
+if ! $PKG_CONFIG --atleast-version 1.0.0 dbus-1; then
+ DBUS_CFLAGS="$DBUS_CFLAGS -DDBUS_API_SUBJECT_TO_CHANGE"
+ AC_MSG_RESULT([setting -DDBUS_API_SUBJECT_TO_CHANGE])
+fi
+
if test x$has_dbus != xno; then
SAFE_LDFLAGS="$LDFLAGS"
LDFLAGS="$DBUS_LIBS"