summaryrefslogtreecommitdiffstats
path: root/server/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-06-18 11:27:58 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-06-19 09:25:42 -0400
commita8f3c276d5f408d39b2474f62e1f80cc97e5a2b0 (patch)
treebecddedb1bf211ca3507a6def8d936a2fcaf41c7 /server/configure.ac
parent45e93b29d1016f1cc2c76e30ec9fbb5144452d59 (diff)
downloadsssd-a8f3c276d5f408d39b2474f62e1f80cc97e5a2b0.tar.gz
sssd-a8f3c276d5f408d39b2474f62e1f80cc97e5a2b0.tar.xz
sssd-a8f3c276d5f408d39b2474f62e1f80cc97e5a2b0.zip
Allow the use of custom CFLAGS on the make command line
Setting CFLAGS explicitly in configure.ac means that they would be overwritten when using e.g. make CFLAGS="-O0 -g" This replaces the explicit setting of CFLAGS with an AM_CONDITIONAL to have Makefile.am set these instead. Also fixes a missing #include that was coincidentally obscured because gcc's -O2 happened to be able to locate it. Setting -O0 revealed the problem.
Diffstat (limited to 'server/configure.ac')
-rw-r--r--server/configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/server/configure.ac b/server/configure.ac
index 77f7ec73b..88032766e 100644
--- a/server/configure.ac
+++ b/server/configure.ac
@@ -26,9 +26,7 @@ AM_GNU_GETTEXT_VERSION([0.17])
m4_pattern_allow([AM_SILENT_RULES])
AM_SILENT_RULES
-if test "$ac_cv_prog_gcc" = yes; then
- CFLAGS="$CFLAGS -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings"
-fi
+AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
AC_CHECK_HEADERS(stdint.h dlfcn.h)
AC_CONFIG_HEADER(config.h)