summaryrefslogtreecommitdiffstats
path: root/server/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-05-10 23:02:21 +0200
committerSimo Sorce <ssorce@redhat.com>2009-05-14 11:41:10 -0400
commitca2fa90f8e7a9399c7c44781f1a032fe10f98cdc (patch)
treeae2ba67c79ac782d9c9e1250f7657dc88fdd43f3 /server/configure.ac
parent50c10e1f61a1bef93a7f768ad6edb28989f1761b (diff)
downloadsssd-ca2fa90f8e7a9399c7c44781f1a032fe10f98cdc.tar.gz
sssd-ca2fa90f8e7a9399c7c44781f1a032fe10f98cdc.tar.xz
sssd-ca2fa90f8e7a9399c7c44781f1a032fe10f98cdc.zip
Manpage generation
Provides a set of make rules for generating UNIX manual pages from DocBook 4.5 source as well as sample manpage for sss_useradd. Automatic generation of manual pages during "make" process is tunable with config parameter "--with-manpages". To rebuild the man pages separately, use the "make doc" target. Before building, the manpages are validated using a DTD schema.
Diffstat (limited to 'server/configure.ac')
-rw-r--r--server/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/server/configure.ac b/server/configure.ac
index 79eb7305c..a6a611a19 100644
--- a/server/configure.ac
+++ b/server/configure.ac
@@ -40,6 +40,8 @@ WITH_POLICYKIT
WITH_TESTS
WITH_INIT_DIR
WITH_SHADOW_UTILS_PATH
+WITH_MANPAGES
+WITH_XML_CATALOG
m4_include(pkg.m4)
m4_include(libpopt.m4)
@@ -64,6 +66,12 @@ if test x$HAVE_TESTS != x; then
fi
PKG_CHECK_MODULES([NSS],[nss])
+if test x$HAVE_MANPAGES != x; then
+ AC_CHECK_FILE($SGML_CATALOG_FILES, [], [AC_MSG_ERROR([could not find XML catalog])])
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ AC_PATH_PROG([XMLLINT], [xmllint])
+fi
+
AC_SUBST(TESTS)
AC_SUBST(EXTRA_OBJ)