summaryrefslogtreecommitdiffstats
path: root/server/config/setup.py
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-10-12 17:20:22 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-13 14:01:17 -0400
commit78e94ac5eec58ec774d73afe9a22220cefb348b9 (patch)
tree6a297eadec9d2305222ffd69a25228e672f60481 /server/config/setup.py
parent0eb99b936eb552cf322a2c4e1f8d751c75f6f129 (diff)
downloadsssd-78e94ac5eec58ec774d73afe9a22220cefb348b9.tar.gz
sssd-78e94ac5eec58ec774d73afe9a22220cefb348b9.tar.xz
sssd-78e94ac5eec58ec774d73afe9a22220cefb348b9.zip
Package SSSDConfig API
Diffstat (limited to 'server/config/setup.py')
-rw-r--r--server/config/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/server/config/setup.py b/server/config/setup.py
new file mode 100644
index 000000000..7f108a3ce
--- /dev/null
+++ b/server/config/setup.py
@@ -0,0 +1,34 @@
+# Authors:
+# Stephen Gallagher <sgallagh@redhat.com>
+#
+# Copyright (C) 2009 Red Hat
+# see file 'COPYING' for use and warranty information
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; version 2 only
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+"""
+Python-level packaging using distutils.
+"""
+
+from distutils.core import setup
+
+setup(
+ name='SSSDConfig',
+ version='1',
+ license='GPLv3+',
+ url='http://fedorahosted.org/sssd',
+ py_modules=[
+ 'SSSDConfig',
+ ],
+)