summaryrefslogtreecommitdiffstats
path: root/server/config/setup.py
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-10-12 17:20:22 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-10-13 11:13:43 -0400
commit103152558622068f54e0be0a4a410e679cd4a975 (patch)
tree8302e2937771f6775809801c1e2141a44d90c4c9 /server/config/setup.py
parentd80577e0475f1e65ec9a481840057ac2fb962546 (diff)
downloadsssd-103152558622068f54e0be0a4a410e679cd4a975.tar.gz
sssd-103152558622068f54e0be0a4a410e679cd4a975.tar.xz
sssd-103152558622068f54e0be0a4a410e679cd4a975.zip
Package SSSDConfig API
Diffstat (limited to 'server/config/setup.py')
-rw-r--r--server/config/setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/server/config/setup.py b/server/config/setup.py
new file mode 100644
index 000000000..7f108a3ce
--- /dev/null
+++ b/server/config/setup.py
@@ -0,0 +1,34 @@
+# Authors:
+# Stephen Gallagher <sgallagh@redhat.com>
+#
+# Copyright (C) 2009 Red Hat
+# see file 'COPYING' for use and warranty information
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; version 2 only
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+"""
+Python-level packaging using distutils.
+"""
+
+from distutils.core import setup
+
+setup(
+ name='SSSDConfig',
+ version='1',
+ license='GPLv3+',
+ url='http://fedorahosted.org/sssd',
+ py_modules=[
+ 'SSSDConfig',
+ ],
+)