summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-09-25 13:20:13 +0200
committerStephen Gallagher <sgallagh@redhat.com>2009-09-25 10:19:56 -0400
commit05315b44feaa9819e62f18477f2c6d20914eb7ce (patch)
tree82e28792e306de9e461ea9dde5203d6a3a9de7fa /server/Makefile.am
parent6cec00b7fe2aed71b8df21d2a0d97df8b448cc85 (diff)
downloadsssd-05315b44feaa9819e62f18477f2c6d20914eb7ce.tar.gz
sssd-05315b44feaa9819e62f18477f2c6d20914eb7ce.tar.xz
sssd-05315b44feaa9819e62f18477f2c6d20914eb7ce.zip
Send debug messages to logfile
Introduces a new option --debug-to-files which makes SSSD output its debug information to a file instead of stderr, which is still the default. Also introduces a new confdb option debug_to_files which does the same, but can be specified per-service in the config file. The logfiles are stored in /var/log/sssd by default. Changes the initscript to log to files by default.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index a5555204f..f43cf188a 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -20,7 +20,7 @@ pluginpath = @pluginpath@
pidpath = @pidpath@
pipepath = @pipepath@
initdir = @initdir@
-shadow_utils_path = @shadow_utils_path@
+logpath = @logpath@
AM_CFLAGS =
if WANT_AUX_INFO
@@ -555,7 +555,7 @@ installsssddirs::
$(DESTDIR)$(dbpath) \
$(DESTDIR)$(pidpath) \
$(DESTDIR)$(initdir) \
- $(DESTDIR)$(shadow_utils_path)
+ $(DESTDIR)$(logpath)
install-exec-hook: installsssddirs