summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-02-01 11:17:03 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-02-03 10:35:18 -0500
commitf4918db9dc26e3585054cc3841f379137bb9f8a6 (patch)
treeecfd0b40a9d9937422afa611a2ebf0167edf5a7c /server/Makefile.am
parent1151bcff3fd6f16d4fe3ca216e3957c1420d7b54 (diff)
downloadsssd-f4918db9dc26e3585054cc3841f379137bb9f8a6.tar.gz
sssd-f4918db9dc26e3585054cc3841f379137bb9f8a6.tar.xz
sssd-f4918db9dc26e3585054cc3841f379137bb9f8a6.zip
Split off libini_config into a shared library
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 38b960889..0770a5ba0 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -145,11 +145,16 @@ else
-lcollection
endif
-INI_CFG_CFLAGS = \
- -I$(srcdir)/../common/ini
-INI_CFG_LIBS = \
- -L$(builddir)/../common/ini/.libs/ \
- -lini_config
+if HAVE_SYSTEM_INI_CONFIG
+ INI_CFG_CFLAGS = $(SYSTEM_INI_CONFIG_CFLAGS)
+ INI_CFG_LIBS = $(SYSTEM_INI_CONFIG_LIBS)
+else
+ INI_CFG_CFLAGS = \
+ -I$(srcdir)/../common/ini
+ INI_CFG_LIBS = \
+ -L$(builddir)/../common/ini/ \
+ -lini_config
+endif
if HAVE_SYSTEM_DHASH
DHASH_CFLAGS = $(SYSTEM_DHASH_CFLAGS)