summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-02-15 16:20:36 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-02-16 16:06:55 -0500
commita40a817535c28712e27fe2c0f87817af43a249a2 (patch)
tree30010a66c2640ea22afb15b836392dcfe7e1acf4 /server/Makefile.am
parentae22be810696f35ac8f09930f0168519ba55350c (diff)
downloadsssd-a40a817535c28712e27fe2c0f87817af43a249a2.tar.gz
sssd-a40a817535c28712e27fe2c0f87817af43a249a2.tar.xz
sssd-a40a817535c28712e27fe2c0f87817af43a249a2.zip
Add test for number of options in IPA and LDAP backends
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index b331cf1d2..21ae79ae3 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -72,7 +72,8 @@ if HAVE_CHECK
refcount-tests \
fail_over-tests \
find_uid-tests \
- auth-tests
+ auth-tests \
+ ipa_ldap_opt-tests
endif
check_PROGRAMS = \
@@ -484,6 +485,7 @@ krb5_utils_tests_LDADD = \
$(CARES_LIBS) \
$(CHECK_LIBS)
+
check_and_open_tests_SOURCES = \
$(SSSD_DEBUG_OBJ) \
tests/check_and_open-tests.c \
@@ -601,6 +603,14 @@ auth_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS)
+ipa_ldap_opt_tests_SOURCES = \
+ tests/ipa_ldap_opt-tests.c
+ipa_ldap_opt_tests_CFLAG = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+ipa_ldap_opt_tests_LDADD = \
+ $(CHECK_LIBS)
+
endif
stress_tests_SOURCES = \