summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <ssorce@redhat.com>2009-11-05 17:23:20 -0500
committerSimo Sorce <ssorce@redhat.com>2009-11-06 17:43:07 -0500
commit8628af2c666bdd073a447156cbd0cb889326b657 (patch)
tree4a3fa2c100308695fc5c33217e12d937ce5d7ea7 /server/Makefile.am
parent1ee2b5ee491eed2bce2df3606a7a570c7ebac8ce (diff)
downloadsssd-8628af2c666bdd073a447156cbd0cb889326b657.tar.gz
sssd-8628af2c666bdd073a447156cbd0cb889326b657.tar.xz
sssd-8628af2c666bdd073a447156cbd0cb889326b657.zip
Split async helpers in multiple files
The size of sdap_async.c was unmanageable. This patch splits it into a generic file with common infrastructure calls, a file that handles connection calls and a file for id related calls.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 9b29350b6..f2a9c96d2 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -273,6 +273,7 @@ dist_noinst_HEADERS = \
providers/ldap/ldap_common.h \
providers/ldap/sdap.h \
providers/ldap/sdap_async.h \
+ providers/ldap/sdap_async_private.h \
providers/ipa/ipa_common.h \
tools/tools_util.h \
tools/sss_sync_ops.h \
@@ -515,6 +516,8 @@ libsss_ipa_la_SOURCES = \
providers/ldap/ldap_auth.c \
providers/ldap/ldap_common.c \
providers/ldap/sdap_async.c \
+ providers/ldap/sdap_async_accounts.c \
+ providers/ldap/sdap_async_connection.c \
providers/ldap/sdap.c \
util/sss_ldap.c \
util/sss_krb5.c \