summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-11-19 18:47:56 -0500
committerStephen Gallagher <sgallagh@redhat.com>2009-11-25 11:03:12 -0500
commitf5aa0c046e75f2ecc2b96424847765c8ccb3a302 (patch)
treedc757760d4579e55172d90a5dae57084c8dccfac /server/Makefile.am
parentb67dbadc979cbe86545e2275223483d429b74747 (diff)
downloadsssd-f5aa0c046e75f2ecc2b96424847765c8ccb3a302.tar.gz
sssd-f5aa0c046e75f2ecc2b96424847765c8ccb3a302.tar.xz
sssd-f5aa0c046e75f2ecc2b96424847765c8ccb3a302.zip
Get TGT in a child process.
To avoid blocking in a synchronous call, the TGT is saved in a separate process Fixes: #277
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 69e5fd38e..c43eb470b 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -56,6 +56,7 @@ sssdlibexec_PROGRAMS = \
sssd_pam \
sssd_be \
krb5_child \
+ ldap_child \
$(sssd_pk) \
$(sssd_info)
@@ -566,6 +567,7 @@ libsss_ldap_la_SOURCES = \
providers/ldap/sdap_async.c \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
+ providers/ldap/sdap_child_helpers.c \
providers/ldap/sdap.c \
util/sss_ldap.c \
util/sss_krb5.c
@@ -622,6 +624,7 @@ libsss_ipa_la_SOURCES = \
providers/ldap/sdap_async.c \
providers/ldap/sdap_async_accounts.c \
providers/ldap/sdap_async_connection.c \
+ providers/ldap/sdap_child_helpers.c \
providers/ldap/sdap.c \
util/sss_ldap.c \
util/sss_krb5.c \
@@ -659,6 +662,22 @@ krb5_child_LDADD = \
$(POPT_LIBS) \
$(KRB5_LIBS)
+ldap_child_SOURCES = \
+ $(SSSD_DEBUG_OBJ) \
+ providers/ldap/ldap_child.c \
+ providers/child_common.c \
+ util/sss_krb5.c
+ldap_child_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(POPT_CFLAGS) \
+ $(KRB5_CFLAGS)
+ldap_child_LDADD = \
+ $(TALLOC_LIBS) \
+ $(TEVENT_LIBS) \
+ $(POPT_LIBS) \
+ $(OPENLDAP_LIBS) \
+ $(KRB5_LIBS)
+
memberof_la_SOURCES = \
ldb_modules/memberof.c
memberof_la_CFLAGS = \