summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorMartin Nagy <mnagy@redhat.com>2009-10-06 01:34:55 +0200
committerSimo Sorce <ssorce@redhat.com>2009-11-06 18:06:05 -0500
commitc391633a8cc03f0fc3be0b7c424b28acf94bc878 (patch)
treee06df7285138bdf7134c4750dfe7b3d3c547312d /server/Makefile.am
parent5f91071ac89de679e9f36e788d7bef757ea0e4bb (diff)
downloadsssd-c391633a8cc03f0fc3be0b7c424b28acf94bc878.tar.gz
sssd-c391633a8cc03f0fc3be0b7c424b28acf94bc878.tar.xz
sssd-c391633a8cc03f0fc3be0b7c424b28acf94bc878.zip
Add simple reference counting wrappers for talloc
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 583baa98a..ca793394c 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -68,7 +68,8 @@ if HAVE_CHECK
resolv-tests \
krb5-utils-tests \
check_and_open-tests \
- files-tests
+ files-tests \
+ refcount-tests
endif
check_PROGRAMS = \
@@ -185,6 +186,7 @@ SSSD_UTIL_OBJ = \
util/backup_file.c \
util/strtonum.c \
util/check_and_open.c \
+ util/refcount.c \
$(SSSD_DEBUG_OBJ)
SSSD_RESPONDER_OBJ = \
@@ -258,6 +260,7 @@ dist_noinst_HEADERS = \
util/strtonum.h \
util/sss_ldap.h \
util/sss_krb5.h \
+ util/refcount.h \
config.h \
monitor/monitor.h \
monitor/monitor_interfaces.h \
@@ -464,6 +467,17 @@ resolv_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS) \
$(CARES_LIBS)
+
+refcount_tests_SOURCES = \
+ tests/refcount-tests.c \
+ tests/common.c \
+ $(CHECK_OBJ) \
+ $(SSSD_UTIL_OBJ)
+refcount_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+refcount_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS)
endif
stress_tests_SOURCES = \