summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorMartin Nagy <mnagy@redhat.com>2009-10-21 17:28:15 +0200
committerStephen Gallagher <sgallagh@redhat.com>2009-10-22 13:56:22 -0400
commitaf40ddb7f307b84dc7f983fd420475809bda0851 (patch)
tree6beb281193703200bc2d519ea642fa1a2b0052e9 /server/Makefile.am
parentf0d7e2a1cacdffcbc84e5ad2bdd04f405dcaeb65 (diff)
downloadsssd-af40ddb7f307b84dc7f983fd420475809bda0851.tar.gz
sssd-af40ddb7f307b84dc7f983fd420475809bda0851.tar.xz
sssd-af40ddb7f307b84dc7f983fd420475809bda0851.zip
Various improvements to the resolv test suite
* The resolv test case can now test for TXT and SRV resolving by specifying -t host and -s host respectively. The -n flag must still be passed in to enable network tests. * Added test for the little complicated resolv_copy_hostent() function. * Leak checking using the new tests common functions. * Fix indentation for test_internet, since the whole function was modified to be able to handle SRV and TXT replies. * Initialize the debug variable in main(). Also removed one unused variable in krb5_utils-tests.c
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index a2c36874a..564d4f16b 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -417,6 +417,7 @@ stress_tests_LDADD = \
if HAVE_CHECK
resolv_tests_SOURCES = \
tests/resolv-tests.c \
+ tests/common.c \
$(SSSD_UTIL_OBJ) \
$(SSSD_RESOLV_OBJ)
resolv_tests_CFLAGS = \