summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2009-11-19 17:53:38 +0100
committerStephen Gallagher <sgallagh@redhat.com>2009-11-23 12:46:30 -0500
commit921b13a1c454aabc5dec6e7f33f7ae3ffa80febf (patch)
treeb614f4f3c53ee8b4f6928a6da23d0b01247ae974 /server/Makefile.am
parent64e5787639836a49ddc589eda65be454c4bdff58 (diff)
downloadsssd-921b13a1c454aabc5dec6e7f33f7ae3ffa80febf.tar.gz
sssd-921b13a1c454aabc5dec6e7f33f7ae3ffa80febf.tar.xz
sssd-921b13a1c454aabc5dec6e7f33f7ae3ffa80febf.zip
Read KDC info from file instead from environment
Then name or IP adress of the KDC is written into the pubconf directory into a file named kdcinfo.REALM. The locator plugin will then read this file and pass the data to the kerberos libraries.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index c40942a75..c52db1908 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -22,6 +22,7 @@ pidpath = @pidpath@
pipepath = @pipepath@
initdir = @initdir@
logpath = @logpath@
+pubconfpath = @pubconfpath@
AM_CFLAGS =
if WANT_AUX_INFO
@@ -432,13 +433,16 @@ krb5_utils_tests_SOURCES = \
tests/krb5_utils-tests.c \
providers/krb5/krb5_utils.c \
providers/krb5/krb5_common.c \
+ providers/data_provider_fo.c \
providers/data_provider_opts.c \
+ $(SSSD_FAILOVER_OBJ) \
$(SSSD_UTIL_OBJ)
krb5_utils_tests_CFLAGS = \
$(AM_CFLAGS) \
$(CHECK_CFLAGS)
krb5_utils_tests_LDADD = \
$(SSSD_LIBS)\
+ $(CARES_LIBS) \
$(CHECK_LIBS)
check_and_open_tests_SOURCES = \
@@ -749,7 +753,8 @@ installsssddirs::
$(DESTDIR)$(dbpath) \
$(DESTDIR)$(pidpath) \
$(DESTDIR)$(initdir) \
- $(DESTDIR)$(logpath)
+ $(DESTDIR)$(logpath) \
+ $(DESTDIR)$(pubconfpath)
install-exec-hook: installsssddirs
if [ "$(DESTDIR)" = "" ]; then \