summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-05-20 19:21:35 +0200
committerSimo Sorce <ssorce@redhat.com>2009-05-26 08:54:39 -0400
commit8c1708124cf1cd4635cf411a9a65e279a241b908 (patch)
treedfd6eaecf13fb2a1d2e781dd0342735dd41d707b /server/Makefile.am
parent43bcf03e6e0e705cbfc66543223042102f48ac94 (diff)
downloadsssd-8c1708124cf1cd4635cf411a9a65e279a241b908.tar.gz
sssd-8c1708124cf1cd4635cf411a9a65e279a241b908.tar.xz
sssd-8c1708124cf1cd4635cf411a9a65e279a241b908.zip
Add some more InfoPipe tests
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 5b0b61a4d..999c4eae3 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -39,6 +39,7 @@ endif
if BUILD_INFOPIPE
sssd_info = sssd_info
infopipe_tests = infopipe-tests
+infopipe_privileged_tests = infopipe-privileged-tests
infopipe_headers = \
infopipe/infopipe_private.h \
infopipe/sysbus.h \
@@ -57,7 +58,8 @@ if BUILD_TESTS
noinst_PROGRAMS = \
sysdb-tests \
stress-tests \
- $(infopipe_tests)
+ $(infopipe_tests) \
+ $(infopipe_privileged_tests)
endif
sssdlib_LTLIBRARIES = \
@@ -334,6 +336,15 @@ infopipe_tests_CFLAGS = \
infopipe_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS)
+
+infopipe_privileged_tests_SOURCES = \
+ tests/infopipe-privileged-tests.c \
+ $(SSSD_UTIL_OBJ)
+infopipe_privileged_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+infopipe_privileged_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS)
endif #BUILD_INFOPIPE
endif #BUILD_TESTS