summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-08-18 10:29:53 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-08-19 10:19:34 -0400
commit519b6bacaec539d5aee041c63d8887cd8baa81af (patch)
tree0ecbe33f29a00eed7224ff2d2c61f05d7a985239 /server/Makefile.am
parenta2e6b54bb5f50bcc3325851ed977892262896dd9 (diff)
downloadsssd-519b6bacaec539d5aee041c63d8887cd8baa81af.tar.gz
sssd-519b6bacaec539d5aee041c63d8887cd8baa81af.tar.xz
sssd-519b6bacaec539d5aee041c63d8887cd8baa81af.zip
Eliminate the --with-tests configure flag
--with-tests was confusing. Since we now build our tests only with 'make check', it doesn't make sense for this to be a configure- time option. We will detect during configure whether the 'check' package is available and we will use them if so. Otherwise, we will only build and execute any test suites that do not rely on the 'check' framework. We will print warning during 'configure' if CHECK is not installed
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am22
1 files changed, 14 insertions, 8 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 7ef7eb7b6..6aa6bec7c 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -49,13 +49,18 @@ sssdlibexec_PROGRAMS = \
$(sssd_pk) \
$(sssd_info)
-if BUILD_TESTS
+if HAVE_CHECK
+ non_interactive_check_based_tests = \
+ sysdb-tests \
+ resolv-tests
+endif
+
check_PROGRAMS = \
- sysdb-tests \
stress-tests \
- resolv-tests
-TESTS = sysdb-tests resolv-tests
-endif
+ $(non_interactive_check_based_tests)
+
+TESTS = \
+ $(non_interactive_check_based_tests)
sssdlib_LTLIBRARIES = \
libsss_ldap.la \
@@ -322,7 +327,7 @@ sss_groupmod_LDADD = \
#################
# Feature Tests #
#################
-if BUILD_TESTS
+if HAVE_CHECK
sysdb_tests_SOURCES = \
tests/sysdb-tests.c \
$(SSSD_UTIL_OBJ)
@@ -331,6 +336,7 @@ sysdb_tests_CFLAGS = \
sysdb_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS)
+endif
stress_tests_SOURCES = \
tests/stress-tests.c \
@@ -338,6 +344,7 @@ stress_tests_SOURCES = \
stress_tests_LDADD = \
$(SSSD_LIBS)
+if HAVE_CHECK
resolv_tests_SOURCES = \
tests/resolv-tests.c \
$(SSSD_UTIL_OBJ) \
@@ -348,8 +355,7 @@ resolv_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS) \
$(CARES_LIBS)
-
-endif #BUILD_TESTS
+endif
####################
# Plugin Libraries #