summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-07-20 16:40:22 +0200
committerSimo Sorce <ssorce@redhat.com>2009-07-24 10:21:43 -0400
commitc8586fd938d5d8fd3db117aa9a496b9a95ca0bfc (patch)
treeb365c5b5b4e1193577a741bd00d89f14228168e0 /server/Makefile.am
parentb6bf81803977318aad8b876a56a42e4a3ffbae6a (diff)
downloadsssd-c8586fd938d5d8fd3db117aa9a496b9a95ca0bfc.tar.gz
sssd-c8586fd938d5d8fd3db117aa9a496b9a95ca0bfc.tar.xz
sssd-c8586fd938d5d8fd3db117aa9a496b9a95ca0bfc.zip
Add async resolver tests
Add some basic unit tests of the async resolver module. One of the tests resolves a name on the Internet, therefore it is off by default and is turned on with the -n switch.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 4ee344bbd..4398259b5 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -52,7 +52,8 @@ sssdlibexec_PROGRAMS = \
if BUILD_TESTS
noinst_PROGRAMS = \
sysdb-tests \
- stress-tests
+ stress-tests \
+ resolv-tests
endif
sssdlib_LTLIBRARIES = \
@@ -328,6 +329,17 @@ stress_tests_SOURCES = \
stress_tests_LDADD = \
$(SSSD_LIBS)
+resolv_tests_SOURCES = \
+ tests/resolv-tests.c \
+ $(SSSD_UTIL_OBJ) \
+ $(SSSD_RESOLV_OBJ)
+resolv_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+resolv_tests_LDADD = \
+ $(SSSD_LIBS) \
+ $(CHECK_LIBS) \
+ $(CARES_LIBS)
+
endif #BUILD_TESTS
####################