summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2009-07-15 18:21:15 +0200
committerSimo Sorce <ssorce@redhat.com>2009-07-24 10:21:43 -0400
commitb6bf81803977318aad8b876a56a42e4a3ffbae6a (patch)
treeedc8117a07bce3e6cbe0a7ff5e2dd674afdcc2dc /server/Makefile.am
parentb919feeb115751ddda02a326e1d2636f1c83e32f (diff)
downloadsssd-b6bf81803977318aad8b876a56a42e4a3ffbae6a.tar.gz
sssd-b6bf81803977318aad8b876a56a42e4a3ffbae6a.tar.xz
sssd-b6bf81803977318aad8b876a56a42e4a3ffbae6a.zip
Add ares helpers into sssd
This patch adds ares parsing functions that are not yet upstreamed together with a private ares header file (ares_dns.h) that contains some necessary macros for parsing common structures in the replies. Users of these two parsing functions must also include the header files ares_parse_{srv,txt}_reply.h that contain the function and structures declarations that should eventually end up in upstream ares.h
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 575f5212e..4ee344bbd 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -151,6 +151,13 @@ SSSD_TOOLS_OBJ = \
SSSD_RESOLV_OBJ = \
resolv/async_resolv.c
+if BUILD_ARES_PARSE_SRV
+ SSSD_RESOLV_OBJ += resolv/ares/ares_parse_srv_reply.c
+endif
+if BUILD_ARES_PARSE_TXT
+ SSSD_RESOLV_OBJ += resolv/ares/ares_parse_txt_reply.c
+endif
+
SSSD_LIBS = \
$(TALLOC_LIBS) \
@@ -200,7 +207,10 @@ dist_noinst_HEADERS = \
providers/ldap/sdap_async.h \
tools/tools_util.h \
krb5_plugin/sssd_krb5_locator_plugin.h \
- resolv/async_resolv.h
+ resolv/async_resolv.h \
+ resolv/ares/ares_parse_srv_reply.h \
+ resolv/ares/ares_parse_txt_reply.h
+
####################
# Program Binaries #