summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2009-09-10 14:43:33 +0200
committerSimo Sorce <ssorce@redhat.com>2009-09-14 12:08:58 -0400
commit945e1f1fab935616bde0d1d64d9e16225b44c183 (patch)
tree24f7f54a3457ea982d90ce3cb6b7b0ab4e10efbe /server/Makefile.am
parent4039db6e6b34330fec51bc765f40e85bf7b61141 (diff)
downloadsssd-945e1f1fab935616bde0d1d64d9e16225b44c183.tar.gz
sssd-945e1f1fab935616bde0d1d64d9e16225b44c183.tar.xz
sssd-945e1f1fab935616bde0d1d64d9e16225b44c183.zip
add krb5ccache_dir and krb5ccname_template option
The configuration options krb5ccache_dir and krb5ccname_template are added to the Kerberos provider to create the user's credential caches the same way as pam_krb5 does. Due to the design of the sssd and the supported ccache types of MIT Kerberos only files are allowed.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 558e7c661..5b5242584 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -59,7 +59,8 @@ if HAVE_CHECK
non_interactive_check_based_tests = \
sysdb-tests \
strtonum-tests \
- resolv-tests
+ resolv-tests \
+ krb5-utils-tests
endif
check_PROGRAMS = \
@@ -228,10 +229,10 @@ dist_noinst_HEADERS = \
providers/dp_backend.h \
providers/providers.h \
providers/krb5/krb5_auth.h \
+ providers/krb5/krb5_utils.h \
providers/ldap/sdap.h \
providers/ldap/sdap_async.h \
tools/tools_util.h \
- krb5_plugin/sssd_krb5_locator_plugin.h \
resolv/async_resolv.h \
resolv/ares/ares_parse_srv_reply.h \
resolv/ares/ares_parse_txt_reply.h
@@ -355,6 +356,16 @@ strtonum_tests_CFLAGS = \
strtonum_tests_LDADD = \
$(SSSD_LIBS) \
$(CHECK_LIBS)
+
+krb5_utils_tests_SOURCES = \
+ $(SSSD_DEBUG_OBJ) \
+ tests/krb5_utils-tests.c \
+ providers/krb5/krb5_utils.c
+krb5_utils_tests_CFLAGS = \
+ $(CHECK_CFLAGS)
+krb5_utils_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(TALLOC_LIBS)
endif
stress_tests_SOURCES = \
@@ -404,6 +415,7 @@ libsss_proxy_la_LDFLAGS = \
-module
libsss_krb5_la_SOURCES = \
+ providers/krb5/krb5_utils.c \
providers/krb5/krb5_auth.c
libsss_krb5_la_CFLAGS = \
$(AM_CFLAGS) \