summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorsbose <sbose@sles10.site>2009-09-09 12:26:07 +0200
committerStephen Gallagher <sgallagh@redhat.com>2009-09-24 21:36:59 -0400
commit7716bef4a7515344a7f552011ba458aaf4582e44 (patch)
treec15f12b8c1e8f19fba47c8b9f1988fc2d9302432 /server/Makefile.am
parent794c66c7b1f8a367b26b8f56c8503007c234333e (diff)
downloadsssd-7716bef4a7515344a7f552011ba458aaf4582e44.tar.gz
sssd-7716bef4a7515344a7f552011ba458aaf4582e44.tar.xz
sssd-7716bef4a7515344a7f552011ba458aaf4582e44.zip
added support for older MIT kerberos versions
- make the build of the locator plugin optional - added a man page for the locator plugin - use krb5.h if krb5/krb5.h cannot be found - added alternatives for missing functions - set -DDBUS_API_SUBJECT_TO_CHANGE if libdbus version is lesser than 1.0.0
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 6ed405a5b..41eeefb42 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -7,7 +7,9 @@ builddir ?= .
sssdlibexecdir = $(libexecdir)/sssd
sssdlibdir = $(libdir)/sssd
ldblibdir = $(libdir)/ldb
+if BUILD_KRB5_LOCATOR_PLUGIN
krb5plugindir = @krb5pluginpath@
+endif
sssdconfdir = $(sysconfdir)/sssd
dbusintrospectdir = $(datarootdir)/sssd/introspect
dbuspolicydir = $(sysconfdir)/dbus-1/system.d
@@ -78,8 +80,10 @@ sssdlib_LTLIBRARIES = \
ldblib_LTLIBRARIES = \
memberof.la
+if BUILD_KRB5_LOCATOR_PLUGIN
krb5plugin_LTLIBRARIES = \
sssd_krb5_locator_plugin.la
+endif
noinst_LTLIBRARIES = \
libsss_crypt.la
@@ -203,8 +207,8 @@ SSSD_LIBS = \
$(COLLECTION_LIBS) \
$(DHASH_LIBS) \
$(REPLACE_LIBS) \
- $(NSS_LIBS) \
- libsss_crypt.la
+ libsss_crypt.la \
+ $(NSS_LIBS)
PYTHON_BINDINGS_LIBS = \
$(TALLOC_LIBS) \
@@ -464,6 +468,7 @@ memberof_la_LDFLAGS = \
-avoid-version \
-module
+if BUILD_KRB5_LOCATOR_PLUGIN
sssd_krb5_locator_plugin_la_SOURCES = \
krb5_plugin/sssd_krb5_locator_plugin.c
sssd_krb5_locator_plugin_la_CFLAGS = \
@@ -472,6 +477,7 @@ sssd_krb5_locator_plugin_la_CFLAGS = \
sssd_krb5_locator_plugin_la_LDFLAGS = \
-avoid-version \
-module
+endif
if BUILD_PYTHON_BINDINGS
pysss_la_SOURCES = \
@@ -501,7 +507,8 @@ XSLTPROC_FLAGS = --catalogs --xinclude --nonet
dist_man_MANS = man/sss_useradd.8 man/sss_userdel.8 man/sss_usermod.8 \
man/sss_groupadd.8 man/sss_groupdel.8 man/sss_groupmod.8 \
- man/sssd.8 man/sssd.conf.5 man/sssd-ldap.5 man/sssd-krb5.5
+ man/sssd.8 man/sssd.conf.5 man/sssd-ldap.5 man/sssd-krb5.5 \
+ man/sssd_krb5_locator_plugin.8
SUFFIXES = .1.xml .1 .3.xml .3 .5.xml .5 .8.xml .8
.1.xml.1: