summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2009-06-15 15:06:40 +0200
committerStephen Gallagher <sgallagh@redhat.com>2009-07-02 08:59:46 -0400
commit43133b835fe97592eba30344805177faab9fb644 (patch)
treeebabeb05e213744d5f1e8a170214cd9e53d6fe9e /server/Makefile.am
parent9a28c36d323c14e31a3895ffe7dc905b815291f8 (diff)
downloadsssd-43133b835fe97592eba30344805177faab9fb644.tar.gz
sssd-43133b835fe97592eba30344805177faab9fb644.tar.xz
sssd-43133b835fe97592eba30344805177faab9fb644.zip
added kerberos locator plugin
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index bed9060bd..b15c23069 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -3,6 +3,7 @@ topdir=.
sssdlibexecdir = $(libexecdir)/sssd
sssdlibdir = $(libdir)/sssd
ldblibdir = $(libdir)/ldb
+krb5plugindir = @krb5pluginpath@
sssdconfdir = $(sysconfdir)/sssd
dbusintrospectdir = $(datarootdir)/sssd/introspect
dbuspolicydir = $(sysconfdir)/dbus-1/system.d
@@ -80,6 +81,9 @@ sssdlib_LTLIBRARIES = \
ldblib_LTLIBRARIES = \
memberof.la
+krb5plugin_LTLIBRARIES = \
+ sssd_krb5_locator_plugin.la
+
noinst_LTLIBRARIES = \
libsss_crypt.la
libsss_crypt_la_SOURCES = \
@@ -208,6 +212,7 @@ dist_noinst_HEADERS = \
providers/dp_backend.h \
providers/providers.h \
tools/tools_util.h \
+ krb5_plugin/sssd_krb5_locator_plugin.h \
$(infopipe_headers) \
$(polkit_headers)
@@ -403,6 +408,15 @@ memberof_la_LDFLAGS = \
-avoid-version \
-module
+sssd_krb5_locator_plugin_la_SOURCES = \
+ krb5_plugin/sssd_krb5_locator_plugin.c
+sssd_krb5_locator_plugin_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(KRB5_CFLAGS)
+sssd_krb5_locator_plugin_la_LDFLAGS = \
+ -avoid-version \
+ -module
+
############
# MANPAGES #
############