summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <ssorce@redhat.com>2009-06-13 12:16:00 -0400
committerSimo Sorce <ssorce@redhat.com>2009-07-08 19:28:38 -0400
commit9f6eb36a630cec8cd172bf35e115262422960de5 (patch)
tree79185e2642c962262d74cb0dbddce4fed419f7cf /server/Makefile.am
parent4553ee7011317554974a3cb8142c748f820f6e6b (diff)
downloadsssd-9f6eb36a630cec8cd172bf35e115262422960de5.tar.gz
sssd-9f6eb36a630cec8cd172bf35e115262422960de5.tar.xz
sssd-9f6eb36a630cec8cd172bf35e115262422960de5.zip
Add async helper functions
These functions use the tevent_req async model, where a pair of _send/_recv functions pilot requests, with additional helpers like _done functions, and where needed multiple stage helpers.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 0627836d3..63d98bcde 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -212,6 +212,8 @@ dist_noinst_HEADERS = \
providers/dp_backend.h \
providers/providers.h \
providers/krb5/krb5_auth.h \
+ providers/ldap/sdap.h \
+ providers/ldap/sdap_async.h \
tools/tools_util.h \
krb5_plugin/sssd_krb5_locator_plugin.h \
$(infopipe_headers) \
@@ -381,7 +383,9 @@ endif #BUILD_TESTS
####################
libsss_ldap_la_SOURCES = \
providers/ldap/ldap_id.c \
- providers/ldap/ldap_auth.c
+ providers/ldap/ldap_auth.c \
+ providers/ldap/sdap_async.c \
+ providers/ldap/sdap.c
libsss_ldap_la_CFLAGS = \
$(AM_CFLAGS) \
$(LDAP_CFLAGS)