summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-08-13 11:17:08 -0400
committerStephen Gallagher <sgallagh@redhat.com>2009-08-14 08:02:17 -0400
commit01c7e801761cff3c58f3de7dd4e08c99da99d7aa (patch)
tree8a1ea24d9dd3322a98e76315768caa1d789153fb /server/Makefile.am
parent2e53c10c68a86c33d97936fce02c3c53aad82bfa (diff)
downloadsssd-01c7e801761cff3c58f3de7dd4e08c99da99d7aa.tar.gz
sssd-01c7e801761cff3c58f3de7dd4e08c99da99d7aa.tar.xz
sssd-01c7e801761cff3c58f3de7dd4e08c99da99d7aa.zip
Don't go to the backend for identical cache entry requests
Currently, if an additional request comes in for a cache entry while that same entry is already in the process of being refreshed, we start a duplicate cache update request. This patch adds allows the cache to maintain a hash table of all in-progress requests and queue up multiple callbacks for updates in progress. Once the data is returned, all of these callbacks will fire.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 9616a391d..8b552558f 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -91,6 +91,12 @@ INI_CFG_LIBS = \
-L$(builddir)/../common/ini/.libs/ \
-lini_config
+DHASH_CFLAGS = \
+ -I$(srcdir)/../common/dhash
+DHASH_LIBS = \
+ -L$(builddir)/../common/dhash/.libs/ \
+ -ldhash
+
AM_CPPFLAGS = -Wall \
-Iinclude \
-I.. \
@@ -107,7 +113,8 @@ AM_CPPFLAGS = -Wall \
$(PCRE_CFLAGS) \
$(REPLACE_CFLAGS) \
$(COLLECTION_CFLAGS) \
- $(INI_CFG_CFLAGS)\
+ $(INI_CFG_CFLAGS) \
+ $(DHASH_CFLAGS) \
-DLIBDIR=\"$(libdir)\" \
-DVARDIR=\"$(localstatedir)\" \
-DSHLIBEXT=\"$(SHLIBEXT)\" \
@@ -174,6 +181,7 @@ SSSD_LIBS = \
$(PCRE_LIBS) \
$(INI_CFG_LIBS) \
$(COLLECTION_LIBS) \
+ $(DHASH_LIBS) \
$(REPLACE_LIBS) \
$(NSS_LIBS) \
libsss_crypt.la