summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-02-01 10:33:28 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-02-03 10:35:17 -0500
commit6e9b349b2738064f6d03b2b127ad47af399aaa10 (patch)
tree6ac7f4f4ea6e3e5447df08f0b287d2381b721e5a /server/Makefile.am
parentee08a65d418413515645278734de1ae984a60456 (diff)
downloadsssd-6e9b349b2738064f6d03b2b127ad47af399aaa10.tar.gz
sssd-6e9b349b2738064f6d03b2b127ad47af399aaa10.tar.xz
sssd-6e9b349b2738064f6d03b2b127ad47af399aaa10.zip
Split off libcollection into a shared library
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am17
1 files changed, 11 insertions, 6 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 3c02f65a8..38b960889 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -133,12 +133,17 @@ dist_noinst_DATA = \
###############################
# Global compilation settings #
###############################
-COLLECTION_CFLAGS = \
- -I$(srcdir)/../common/collection \
- -I$(srcdir)/../common/trace
-COLLECTION_LIBS = \
- -L$(builddir)/../common/collection/.libs/ \
- -lcollection
+
+if HAVE_SYSTEM_COLLECTION
+ COLLECTION_CFLAGS = $(SYSTEM_COLLECTION_CFLAGS)
+ COLLECTION_LIBS = $(SYSTEM_COLLECTION_LIBS)
+else
+ COLLECTION_CFLAGS = \
+ -I$(srcdir)/../common/collection
+ COLLECTION_LIBS = \
+ -L$(builddir)/../common/collection \
+ -lcollection
+endif
INI_CFG_CFLAGS = \
-I$(srcdir)/../common/ini