summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-01-12 18:00:49 +0100
committerStephen Gallagher <sgallagh@redhat.com>2010-01-20 08:55:59 -0500
commit30dcfad596af29830cd45adaebeb174a24151a34 (patch)
tree07d114c00bedbd9bc32995eaec108ac92143922e /server/Makefile.am
parenta2ad4811428a48830d040051c59eca6e13512710 (diff)
downloadsssd-30dcfad596af29830cd45adaebeb174a24151a34.tar.gz
sssd-30dcfad596af29830cd45adaebeb174a24151a34.tar.xz
sssd-30dcfad596af29830cd45adaebeb174a24151a34.zip
sss_groupshow - a utility to print properties of a local group
This patch adds a utility called sss_groupshow that allows user to print properties of a group in the local domain. Fixes: #306
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 9d17ee772..fc521c852 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -49,7 +49,8 @@ sbin_PROGRAMS = \
sss_groupadd \
sss_groupdel \
sss_usermod \
- sss_groupmod
+ sss_groupmod \
+ sss_groupshow
sssdlibexec_PROGRAMS = \
sssd_nss \
@@ -413,6 +414,13 @@ sss_groupmod_SOURCES = \
sss_groupmod_LDADD = \
$(TOOLS_LIBS)
+sss_groupshow_SOURCES = \
+ tools/sss_groupshow.c \
+ $(SSSD_UTIL_OBJ) \
+ $(SSSD_TOOLS_OBJ)
+sss_groupshow_LDADD = \
+ $(TOOLS_LIBS)
+
#################
# Feature Tests #
#################
@@ -747,7 +755,8 @@ XSLTPROC_FLAGS = --catalogs --xinclude --nonet
dist_man_MANS = man/sss_useradd.8 man/sss_userdel.8 man/sss_usermod.8 \
man/sss_groupadd.8 man/sss_groupdel.8 man/sss_groupmod.8 \
man/sssd.8 man/sssd.conf.5 man/sssd-ldap.5 man/sssd-krb5.5 \
- man/sssd-ipa.5 man/sssd_krb5_locator_plugin.8
+ man/sssd-ipa.5 man/sssd_krb5_locator_plugin.8 \
+ man/sss_groupshow.8
SUFFIXES = .1.xml .1 .3.xml .3 .5.xml .5 .8.xml .8
.1.xml.1: