summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2009-11-04 12:39:00 +0100
committerStephen Gallagher <sgallagh@redhat.com>2009-11-20 16:46:47 -0500
commit0e4eba0a994d286ae0832adc1731ab2dc10c5ff9 (patch)
treeb787c77df7ef16d0fcae46a2177dc039beb4d7c1 /server/Makefile.am
parent53b4c8fdb26ac799544f8ef8f12e0cadac8ea5e1 (diff)
downloadsssd-0e4eba0a994d286ae0832adc1731ab2dc10c5ff9.tar.gz
sssd-0e4eba0a994d286ae0832adc1731ab2dc10c5ff9.tar.xz
sssd-0e4eba0a994d286ae0832adc1731ab2dc10c5ff9.zip
Add ipa_auth
To support IPA DS to Kerberos password migration a seperate authentication target is added. It calls the Kerberos authentication target and in the case of a 'Preauthentication Error' the LDAP authentication target. On success the Kerberos target is called again to request the TGT.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index fc2ac94d5..4259f6cf7 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -299,6 +299,7 @@ dist_noinst_HEADERS = \
providers/ipa/ipa_common.h \
providers/ipa/ipa_access.h \
providers/ipa/ipa_timerules.h \
+ providers/ipa/ipa_auth.h \
tools/tools_util.h \
tools/sss_sync_ops.h \
resolv/async_resolv.h \
@@ -598,6 +599,7 @@ libsss_krb5_la_LDFLAGS = \
libsss_ipa_la_SOURCES = \
providers/ipa/ipa_init.c \
providers/ipa/ipa_common.c \
+ providers/ipa/ipa_auth.c \
providers/ipa/ipa_access.c \
providers/ipa/ipa_timerules.c \
providers/ldap/ldap_id.c \