summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-08-31 15:32:39 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 17:04:36 +0200
commita20685bb2ffdb08e61a4e26e90d2dc2ba7b3669e (patch)
treee159c9ac25d0eb5af2979af37e0dde94a75b447e /configure.ac
parent24a4c00d7f2d7a12a32ee143d6c23aa3734ab049 (diff)
downloadsssd-a20685bb2ffdb08e61a4e26e90d2dc2ba7b3669e.tar.gz
sssd-a20685bb2ffdb08e61a4e26e90d2dc2ba7b3669e.tar.xz
sssd-a20685bb2ffdb08e61a4e26e90d2dc2ba7b3669e.zip
AUTOTOOLS: Refactor unicode library detection
If $libdir is not in default library path libunistring cannot be found. (pkg-config can not be used in this case). This patch helps to search libunistring in "$libdir" directory. In refactoring part, indentation was updated to be more readable and some duplicated parts were removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 03070239a..00290e82f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,16 +155,15 @@ m4_include([src/util/signal.m4])
WITH_UNICODE_LIB
if test x$unicode_lib = xlibunistring; then
- m4_include([src/external/libunistring.m4])
- AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
- UNICODE_LIBS=-lunistring
- AC_SUBST(UNICODE_LIBS)
+ m4_include([src/external/libunistring.m4])
+ AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=$UNISTRING_LIBS
else
- m4_include([src/external/glib.m4])
- AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using libunistring for unicode])
- UNICODE_LIBS=$GLIB2_LIBS
- AC_SUBST(UNICODE_LIBS)
+ m4_include([src/external/glib.m4])
+ AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using glib2 for unicode])
+ UNICODE_LIBS=$GLIB2_LIBS
fi
+AC_SUBST(UNICODE_LIBS)
WITH_INITSCRIPT
if test x$initscript = xsystemd; then