summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lukas.slebodnik@intrak.sk>2013-08-30 23:13:26 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 17:20:52 +0200
commit9c393e2c39e8d3a00a1ba399a80c4c3291857242 (patch)
tree223786ebd790f3c974fb6753f7014772cc17ba89 /configure.ac
parente64a66e620aad51c1fada6138362c5a186af178a (diff)
downloadsssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.tar.gz
sssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.tar.xz
sssd-9c393e2c39e8d3a00a1ba399a80c4c3291857242.zip
AUTOTOOLS: More robust detection of inotify.
We checked only header file "sys/inotify" for detection whether inotify works. Some platforms do not have built in inotify, but contain library, which provides inotify-compatible interface. This patch adds more robust detection of inotify in configuration time and appends linker flags to Makefile if inotify is provided by library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 00290e82f..cc25be511 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,7 @@ m4_include([src/external/libnl.m4])
m4_include([src/external/systemd.m4])
m4_include([src/external/pac_responder.m4])
m4_include([src/util/signal.m4])
+m4_include([src/external/inotify.m4])
WITH_UNICODE_LIB
if test x$unicode_lib = xlibunistring; then
@@ -247,7 +248,7 @@ if test x$cryptolib = xlibcrypto; then
AM_CHECK_LIBCRYPTO
fi
-AC_CHECK_HEADERS([sys/inotify.h])
+AM_CHECK_INOTIFY
AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))