summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-01-25 10:57:54 -0500
committerJakub Hrozek <jhrozek@redhat.com>2013-01-28 16:04:25 +0100
commit5c17895a272b06897608d951ea4e60c539138208 (patch)
treed3b795486b1fe166802b5657bbaf4bacd6b70941 /configure.ac
parent31778d703734bd924819d6c7fe80f8625b93f078 (diff)
downloadsssd-5c17895a272b06897608d951ea4e60c539138208.tar.gz
sssd-5c17895a272b06897608d951ea4e60c539138208.tar.xz
sssd-5c17895a272b06897608d951ea4e60c539138208.zip
TOOLS: Compile on old platforms such as RHEL5
Provides compatible declarations for modern file management functions such as futimens or opening with the O_CLOEXEC flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ee5844f7..57dec022a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,10 @@ AC_CHECK_FUNCS([ pthread_mutexattr_setrobust \
pthread_mutex_consistent_np ])
LIBS=$SAVE_LIBS
+# Check for presence of modern functions for setting file timestamps
+AC_CHECK_FUNCS([ utimensat \
+ futimens ])
+
#Check for PAM headers
AC_CHECK_HEADERS([security/pam_appl.h security/pam_misc.h security/pam_modules.h],
[AC_CHECK_LIB(pam, pam_get_item, [ PAM_LIBS="-lpam" ], [AC_MSG_ERROR([PAM must support pam_get_item])])],