summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge McCollister <George.McCollister@gmail.com>2012-06-19 12:36:28 -0500
committerStephen Gallagher <sgallagh@redhat.com>2012-06-26 09:01:26 -0400
commite07a94a66985b674c5df11ca466792902164c4e2 (patch)
treef6e3443b5665c2a73f56a6dde999f21d25338473 /configure.ac
parent9dadbd5cac8b25a198633508a27747039be43c34 (diff)
downloadsssd-e07a94a66985b674c5df11ca466792902164c4e2.tar.gz
sssd-e07a94a66985b674c5df11ca466792902164c4e2.tar.xz
sssd-e07a94a66985b674c5df11ca466792902164c4e2.zip
libcrypto fully implemented
Implemented working versions of the following functions for libcrypto: sss_base64_encode sss_base64_decode sss_hmac_sha1 sss_password_encrypt sss_password_decrypt test_encrypt_decrypt now expects EOK from libcrypto. test_hmac_sha1 now expects EOK from libcrypto. Added test_base64_encode to test base64 encoding implementation. Added test_base64_decode to test base64 decoding implementation. Signed-off-by: George McCollister <George.McCollister@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f5391bde..5bb82a77d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,7 @@ WITH_SUDO
WITH_SUDO_LIB_PATH
WITH_AUTOFS
WITH_SSH
+WITH_CRYPTO
m4_include([src/external/pkg.m4])
m4_include([src/external/libpopt.m4])
@@ -214,8 +215,12 @@ if test x$HAVE_SYSTEMD_UNIT != x; then
AM_CHECK_SYSTEMD
fi
-AM_CHECK_NSS
-AM_CONDITIONAL([HAVE_NSS], [test x"$NSS_CFLAGS" != x])
+if test x$cryptolib = xnss; then
+ AM_CHECK_NSS
+fi
+if test x$cryptolib = xlibcrypto; then
+ AM_CHECK_LIBCRYPTO
+fi
AC_CHECK_HEADERS([sys/inotify.h])