summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-07-12 21:22:22 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-07-13 11:00:47 -0400
commit72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067 (patch)
tree6702b1ff93ef9b3fd66ff5b921bb9732bd7f96a0 /configure.ac
parent22d268c88f6d324b3a66846af007b06488eddae7 (diff)
downloadsssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.tar.gz
sssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.tar.xz
sssd-72e60fd4eabcfbcdbfe01e8c38b94052bc6c2067.zip
Fix python HBAC bindings for python <= 2.4
Several parts of the HBAC python bindings did not work with old Python versions, such as the one shipped in RHEL5. The changes include: * a compatibility wrapper around python set object * PyModule_AddIntMacro compat macro * Py_ssize_t compat definition * Do not use PyUnicode_FromFormat * several function prototypes and structures used to have "char arguments where they have "const char *" in recent versions. This caused compilation warnings this patch mitigates by using the discard_const hack on python 2.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cf3137f8..0e2e6d44a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,7 @@ if test x$HAVE_PYTHON_BINDINGS != x; then
AM_CHECK_PYTHON_HEADERS([],
AC_MSG_ERROR([Could not find python headers]))
AM_PYTHON_CONFIG
+ AM_CHECK_PYTHON_COMPAT
fi
if test x$HAVE_SELINUX != x; then