summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Kos <okos@redhat.com>2013-02-11 12:59:01 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-02-11 15:45:10 +0100
commitf5bb0ff1c3c59cf77bd7bb7e84cadcc68bef445e (patch)
tree32ea0f7ba5bb24776a9688229fba20afbab11a43 /configure.ac
parentf03094b1950325fd0d7f59fd626ac3d34ce56731 (diff)
downloadsssd-bd78e47cf6e2bce1ff0e88404cfae3fea54d8b46.tar.gz
sssd-bd78e47cf6e2bce1ff0e88404cfae3fea54d8b46.tar.xz
sssd-bd78e47cf6e2bce1ff0e88404cfae3fea54d8b46.zip
TOOLS: Compile on old platforms such as RHEL5sssd-1_5_17
Provides compatible declarations for modern file management functions such as futimens or opening with the O_CLOEXEC flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index caac10fbe..3885b595f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,10 @@ AC_COMPILE_IFELSE(
[AC_DEFINE([HAVE_PTHREAD], [1], [Pthread mutexes available.])],
[AC_MSG_WARN([Pthread library not found! Clients will not be thread safe...])])
+# Check for presence of modern functions for setting file timestamps
+AC_CHECK_FUNCS([ utimensat \
+ futimens ])
+
#Check for PAM headers
AC_CHECK_HEADERS([security/pam_appl.h security/pam_misc.h security/pam_modules.h],
[AC_CHECK_LIB(pam, pam_get_item, [ PAM_LIBS="-lpam" ], [AC_MSG_ERROR([PAM must support pam_get_item])])],