summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-07-12 21:22:22 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-08-01 12:18:34 -0400
commit833eda9de40ad28e966f8f883dba8e187f8efd32 (patch)
tree997b49118a7b16ed46f2b71108cd6f4aba35380c /configure.ac
parent38f5e997f02259107016543c9e60f35111cc9aab (diff)
downloadsssd-833eda9de40ad28e966f8f883dba8e187f8efd32.tar.gz
sssd-833eda9de40ad28e966f8f883dba8e187f8efd32.tar.xz
sssd-833eda9de40ad28e966f8f883dba8e187f8efd32.zip
Fix python HBAC bindings for python <= 2.4
Several parts of the HBAC python bindings did not work with old Python versions, such as the one shipped in RHEL5. The changes include: * a compatibility wrapper around python set object * PyModule_AddIntMacro compat macro * Py_ssize_t compat definition * Do not use PyUnicode_FromFormat * several function prototypes and structures used to have "char arguments where they have "const char *" in recent versions. This caused compilation warnings this patch mitigates by using the discard_const hack on python 2.4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17cc8bf78..bc41674ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,7 @@ if test x$HAVE_PYTHON_BINDINGS != x; then
AM_CHECK_PYTHON_HEADERS([],
AC_MSG_ERROR([Could not find python headers]))
AM_PYTHON_CONFIG
+ AM_CHECK_PYTHON_COMPAT
fi
if test x$HAVE_SELINUX != x; then