summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-05-23 13:14:37 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-11 19:44:56 +0200
commitaac071824f6c98003f30d49ab440c15b4b53692c (patch)
treefe782fd74b15995483e55629c5f9e0c443fde171 /configure.ac
parenta4bf85ccc902490c3b75b44532010fbb32169801 (diff)
downloadsssd-aac071824f6c98003f30d49ab440c15b4b53692c.tar.gz
sssd-aac071824f6c98003f30d49ab440c15b4b53692c.tar.xz
sssd-aac071824f6c98003f30d49ab440c15b4b53692c.zip
Enable printf format string checking
https://fedorahosted.org/sssd/ticket/1945
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ebce20254..c389bec4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,6 +268,24 @@ if test x"$sss_client_cv_attribute_destructor" = xyes ; then
[whether compiler supports __attribute__((destructor))])
fi
+AC_CACHE_CHECK([whether compiler supports __attribute__((format))],
+ sss_cv_attribute_format,
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_SOURCE(
+ [void debug_fn(const char *format, ...) __attribute__ ((format (printf, 1, 2)));]
+ )],
+ [sss_cv_attribute_format=yes],
+ [
+ AC_MSG_RESULT([no])
+ AC_MSG_WARN([compiler does NOT support __attribute__((format))])
+ ])
+ ])
+
+if test x"$sss_cv_attribute_format" = xyes ; then
+ AC_DEFINE(HAVE_FUNCTION_ATTRIBUTE_FORMAT, 1,
+ [whether compiler supports __attribute__((format))])
+fi
+
PKG_CHECK_MODULES([CHECK], [check >= 0.9.5], [have_check=1], [have_check=])
if test x$have_check = x; then
AC_MSG_WARN([Without the 'CHECK' libraries, you will be unable to run all tests in the 'make check' suite])