summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2012-01-31 16:39:36 +0100
committerStephen Gallagher <sgallagh@redhat.com>2012-02-01 19:33:29 -0500
commit4d81fe27ced3d2e96866aeaf61661a925cb8edf1 (patch)
tree2490570d947acaca58e5e9a5196a34372154b037 /configure.ac
parent3989d650bec60c66c02bc72f7313acdc876aae58 (diff)
downloadsssd-4d81fe27ced3d2e96866aeaf61661a925cb8edf1.tar.gz
sssd-4d81fe27ced3d2e96866aeaf61661a925cb8edf1.tar.xz
sssd-4d81fe27ced3d2e96866aeaf61661a925cb8edf1.zip
Use profiling Docbook XSLT only if available, fall back to normal
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 69feac683..baea45ca1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,11 +157,27 @@ fi
if test x$HAVE_MANPAGES != x; then
CHECK_XML_TOOLS
+
+ DOCBOOK_XSLT=http://docbook.sourceforge.net/release/xsl/current/manpages/profile-docbook.xsl
CHECK_STYLESHEET([$SGML_CATALOG_FILES],
- [http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
- [Docbook XSL templates])
+ [$DOCBOOK_XSLT],
+ [Docbook XSL profiling templates],
+ [HAVE_PROFILE_CATALOGS=1],
+ [AC_MSG_WARN([Man pages might contain documentation for experimental features])])
+
+ if test x$HAVE_PROFILE_CATALOGS == x; then
+ DOCBOOK_XSLT=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+ CHECK_STYLESHEET([$SGML_CATALOG_FILES],
+ [$DOCBOOK_XSLT],
+ [Docbook XSL templates],
+ [],
+ [AC_MSG_ERROR([could not find the docbook xsl catalog])])
+ fi
+
AC_CHECK_PROG([PO4A],[po4a],[po4a],[no])
+ AC_SUBST(DOCBOOK_XSLT)
fi
+AM_CONDITIONAL([HAVE_PROFILE_CATALOGS], [test "x$HAVE_PROFILE_CATALOGS" != "x"])
AM_CONDITIONAL([HAVE_MANPAGES], [test "x$HAVE_MANPAGES" != "x"])
AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])