summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-08-30 23:13:26 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 17:17:52 +0200
commit9917c138d9a270deb5820915384fbde751190c2a (patch)
treed36c7bd18c21dc8b42a4b76d83c085b1d5419257 /configure.ac
parenta31df2979265339f71fe3e2d587c4176375b1eff (diff)
downloadsssd-9917c138d9a270deb5820915384fbde751190c2a.tar.gz
sssd-9917c138d9a270deb5820915384fbde751190c2a.tar.xz
sssd-9917c138d9a270deb5820915384fbde751190c2a.zip
AUTOTOOLS: More robust detection of inotify.
We checked only header file "sys/inotify" for detection whether inotify works. Some platforms do not have built in inotify, but contain library, which provides inotify-compatible interface. This patch adds more robust detection of inotify in configuration time and appends linker flags to Makefile if inotify is provided by library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cdf46d4c7..ebce20254 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,7 @@ m4_include([src/external/libnl.m4])
m4_include([src/external/systemd.m4])
m4_include([src/external/pac_responder.m4])
m4_include([src/external/signal.m4])
+m4_include([src/external/inotify.m4])
m4_include([src/external/libndr_nbt.m4])
WITH_UNICODE_LIB
@@ -251,7 +252,7 @@ if test x$cryptolib = xlibcrypto; then
AM_CHECK_LIBCRYPTO
fi
-AC_CHECK_HEADERS([sys/inotify.h])
+AM_CHECK_INOTIFY
AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))