summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-03-18 10:39:50 -0400
committerJakub Hrozek <jhrozek@redhat.com>2013-03-20 12:38:56 +0100
commit8c294c1cd4d721818a59684cf7f2b36123f79163 (patch)
treee85a420907c8b3fe3cb268ec34913fd5df0fb337 /configure.ac
parentec26d836b1b2a41ec2692976a539da51f261412b (diff)
downloadsssd-8c294c1cd4d721818a59684cf7f2b36123f79163.tar.gz
sssd-8c294c1cd4d721818a59684cf7f2b36123f79163.tar.xz
sssd-8c294c1cd4d721818a59684cf7f2b36123f79163.zip
BUILD: Always run distcheck and RPM tests in /dev/shm
Some of the tests (such as the sysdb tests) are highly I/O limited. By running them on a ramdisk, we can significantly speed up the test runs when doing a distcheck or RPM build. https://fedorahosted.org/sssd/ticket/1840
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4b1cfba26..3533502d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,8 @@ AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
AM_CONDITIONAL([HAVE_CMOCKA], [test x$have_cmocka = xyes])
+AM_CONDITIONAL([HAVE_DEVSHM], [test -d /dev/shm])
+
abs_build_dir=`pwd`
AC_DEFINE_UNQUOTED([ABS_BUILD_DIR], ["$abs_build_dir"], [Absolute path to the build directory])
AC_SUBST([abs_builddir], $abs_build_dir)