summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOndrej Kos <okos@redhat.com>2013-02-18 14:43:19 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-03-27 20:15:52 +0100
commit539b1be3507abdf8ac235b06eeed5011b0b5cde2 (patch)
treede8f928b6b46a95af9a1a11d6f0f7ba6d72fcc9f /configure.ac
parent78eba1cdd8e337d07b536afd9d6043482c88208e (diff)
downloadsssd-539b1be3507abdf8ac235b06eeed5011b0b5cde2.tar.gz
sssd-539b1be3507abdf8ac235b06eeed5011b0b5cde2.tar.xz
sssd-539b1be3507abdf8ac235b06eeed5011b0b5cde2.zip
Provide libnl3 support
https://fedorahosted.org/sssd/ticket/812 Update the monitor code to be using the new libnl3 API. Changed configure option --with-libnl By default, it tries to build with libnl3, if not found, then with libnl1, if this isn't found either, build proceeds without libnl, just with warning. Specifing --with-libnl=<libnl3|libnl1|no> checks for the specific given version, if not found, configure ends with error.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0d8108405..5d47c4e63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,7 +114,6 @@ WITH_PYTHON_BINDINGS
WITH_SELINUX
WITH_NSCD
WITH_SEMANAGE
-WITH_LIBNL
WITH_NOLOGIN_SHELL
WITH_APP_LIBS
WITH_SUDO
@@ -164,6 +163,8 @@ else
AC_SUBST(UNICODE_LIBS)
fi
+WITH_LIBNL
+
WITH_INITSCRIPT
if test x$initscript = xsystemd; then
WITH_SYSTEMD_UNIT_DIR
@@ -231,10 +232,6 @@ if test x$HAVE_SEMANAGE != x -a x$HAVE_SELINUX != x; then
AM_CHECK_SEMANAGE
fi
-if test x$BUILD_LIBNL != x; then
- AM_CHECK_LIBNL
-fi
-
if test x$HAVE_SYSTEMD_UNIT != x; then
AM_CHECK_SYSTEMD
fi