summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2011-04-05 15:42:13 +0200
committerStephen Gallagher <sgallagh@redhat.com>2011-04-12 09:26:26 -0400
commit2a5790216f57e9bdfb2930d52860bb5300366536 (patch)
tree41d9ad9913dcc3cda3aed38f64f5f1c6ef251d18 /configure.ac
parent00e9f24707a2d221ed2be40289669e4fd731713e (diff)
downloadsssd-2a5790216f57e9bdfb2930d52860bb5300366536.tar.gz
sssd-2a5790216f57e9bdfb2930d52860bb5300366536.tar.xz
sssd-2a5790216f57e9bdfb2930d52860bb5300366536.zip
Provide a configuration option to use systemd unit file
https://fedorahosted.org/sssd/ticket/837
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f0fa07257..6a57aa4fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,8 +119,12 @@ m4_include([src/external/nscd.m4])
m4_include([src/external/nsupdate.m4])
m4_include([src/external/libkeyutils.m4])
m4_include([src/external/libnl.m4])
+m4_include([src/external/systemd.m4])
m4_include([src/util/signal.m4])
+WITH_INITSCRIPT
+WITH_SYSTEMD_UNIT_DIR
+
PKG_CHECK_MODULES([DBUS],[dbus-1])
dnl if test -n "`$PKG_CONFIG --modversion dbus-1 | grep '^0\.'`" ; then
if ! $PKG_CONFIG --atleast-version 1.0.0 dbus-1; then
@@ -165,6 +169,10 @@ if test x$BUILD_LIBNL != x; then
AM_CHECK_LIBNL
fi
+if test x$HAVE_SYSTEMD_UNIT != x; then
+ AM_CHECK_SYSTEMD
+fi
+
AC_CHECK_HEADERS([sys/inotify.h])
AC_CHECK_HEADERS([sasl/sasl.h],,AC_MSG_ERROR([Could not find SASL headers]))