summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-12-02 11:59:20 -0500
committerStephen Gallagher <sgallagh@redhat.com>2011-12-05 13:49:58 -0500
commitd488258da8c9d419af6d8ac4f88732b6494455c4 (patch)
treea3000643d499856820d0e5fd198d0a98fb817e7a /configure.ac
parent46dfa69060f22a443d4ad9d2bf34441ff1adf2d3 (diff)
downloadsssd-d488258da8c9d419af6d8ac4f88732b6494455c4.tar.gz
sssd-d488258da8c9d419af6d8ac4f88732b6494455c4.tar.xz
sssd-d488258da8c9d419af6d8ac4f88732b6494455c4.zip
Allow using Glib for UTF8 support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5e0878bca..5417d53a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,7 +123,19 @@ m4_include([src/external/nsupdate.m4])
m4_include([src/external/libkeyutils.m4])
m4_include([src/external/libnl.m4])
m4_include([src/util/signal.m4])
-m4_include([src/external/libunistring.m4])
+
+WITH_UNICODE_LIB
+if test x$unicode_lib = xlibunistring; then
+ m4_include([src/external/libunistring.m4])
+ AC_DEFINE_UNQUOTED(HAVE_LIBUNISTRING, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=-lunistring
+ AC_SUBST(UNICODE_LIBS)
+else
+ m4_include([src/external/glib.m4])
+ AC_DEFINE_UNQUOTED(HAVE_GLIB2, 1, [Using libunistring for unicode])
+ UNICODE_LIBS=$GLIB2_LIBS
+ AC_SUBST(UNICODE_LIBS)
+fi
PKG_CHECK_MODULES([DBUS],[dbus-1])
dnl if test -n "`$PKG_CONFIG --modversion dbus-1 | grep '^0\.'`" ; then