summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-01-25 10:57:54 -0500
committerJakub Hrozek <jhrozek@redhat.com>2013-01-28 16:09:18 +0100
commit48130eef6c5c64a07094b9e8582ba358b2048f24 (patch)
tree7476d5010810b6ed25453dc5660c1556878c0dd6 /configure.ac
parent579e1e23fb0bc7d6d4837cefb5b1c971cbd2223f (diff)
downloadsssd-48130eef6c5c64a07094b9e8582ba358b2048f24.tar.gz
sssd-48130eef6c5c64a07094b9e8582ba358b2048f24.tar.xz
sssd-48130eef6c5c64a07094b9e8582ba358b2048f24.zip
TOOLS: Compile on old platforms such as RHEL5
Provides compatible declarations for modern file management functions such as futimens or opening with the O_CLOEXEC flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 471c7ac68..af976151a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,10 @@ AC_CHECK_FUNCS([ pthread_mutexattr_setrobust \
pthread_mutex_consistent_np ])
LIBS=$SAVE_LIBS
+# Check for presence of modern functions for setting file timestamps
+AC_CHECK_FUNCS([ utimensat \
+ futimens ])
+
#Check for PAM headers
AC_CHECK_HEADERS([security/pam_appl.h security/pam_misc.h security/pam_modules.h],
[AC_CHECK_LIB(pam, pam_get_item, [ PAM_LIBS="-lpam" ], [AC_MSG_ERROR([PAM must support pam_get_item])])],