summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-10-01 14:26:34 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-06 14:22:46 +0200
commit87d3b47abba6a40fcf809c85a2b138bc1013d9c5 (patch)
tree839f3226ae64d1472802558ee24a23204404734d /configure.ac
parentd7d3ee1b8ab7a05129c83da8a185351d7c751c1c (diff)
downloadsssd-87d3b47abba6a40fcf809c85a2b138bc1013d9c5.tar.gz
sssd-87d3b47abba6a40fcf809c85a2b138bc1013d9c5.tar.xz
sssd-87d3b47abba6a40fcf809c85a2b138bc1013d9c5.zip
BUILD: Use $(MKDIR_P) in Makefile.am
It was suggested by the Fedora automake maintainer to use the autoconf macro $(MKDIR_P) instead of calling "mkdir -p" directly as the macro is more portable and might actually expand to something else than "mkdir -p" on some platforms (usually it would be a variant of install.sh) Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e1722deb..2852c2f8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,10 @@ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
AC_DISABLE_STATIC
AC_PROG_INSTALL
AC_PROG_LIBTOOL
+AC_PROG_MKDIR_P
+m4_ifdef([AC_PROG_MKDIR_P],
+ [AC_PROG_MKDIR_P],
+ [MKDIR_P="mkdir -p"])
LT_LIB_DLLOAD
AC_CONFIG_MACRO_DIR([m4])
AM_GNU_GETTEXT([external])