summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-03-11 12:28:23 -0400
committerStephen Gallagher <sgallagh@redhat.com>2013-03-11 13:31:01 -0400
commit50fe3d79ab12b795a687b676761bef265701626a (patch)
tree18ff5036befb552ef7cf37f21351bda033875f36 /configure.ac
parent150b76e13b7c4f3ccf1d709bf517ca2af6b2c9a2 (diff)
downloadsssd-50fe3d79ab12b795a687b676761bef265701626a.tar.gz
sssd-50fe3d79ab12b795a687b676761bef265701626a.tar.xz
sssd-50fe3d79ab12b795a687b676761bef265701626a.zip
BUILD: Fix cmocka detection
We were not properly detecting that cmocka was unavailable. It was expecting an empty value and getting "no" instead. This patch corrects the expectation, so we will now skip building and running cmocka tests on platforms that do not have it available. Also, we were missing the cmocka header files in the distribution tarball, so 'make distcheck' was failing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0e7712389..4b1cfba26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -270,7 +270,7 @@ AC_PATH_PROG([DOXYGEN], [doxygen], [false])
AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
-AM_CONDITIONAL([HAVE_CMOCKA], [test x$have_cmocka != x])
+AM_CONDITIONAL([HAVE_CMOCKA], [test x$have_cmocka = xyes])
abs_build_dir=`pwd`
AC_DEFINE_UNQUOTED([ABS_BUILD_DIR], ["$abs_build_dir"], [Absolute path to the build directory])