summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-07-26 14:58:58 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-10 13:56:06 +0200
commit40b2be4f4312470044cdef460b02b66003f5c85f (patch)
treed20501c5ac37deee83a681d47b8af769a151d10a /configure.ac
parent9df7cddb68c61ef4e0397c196604999c68f4be0d (diff)
downloadsssd-40b2be4f4312470044cdef460b02b66003f5c85f.tar.gz
sssd-40b2be4f4312470044cdef460b02b66003f5c85f.tar.xz
sssd-40b2be4f4312470044cdef460b02b66003f5c85f.zip
BUILD: Detect nss_wrapper and uid_wrapper during configure
Unit testing the utilities to become another user requires the use of the cwrap libraries. This patch augments our build system with macros to detect the nss_wrapper and and uid_wrapper libraries. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2852c2f8e..1edf4cb19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,7 @@ m4_include([src/external/samba.m4])
m4_include([src/external/sasl.m4])
m4_include([src/external/configlib.m4])
m4_include([src/external/libnfsidmap.m4])
+m4_include([src/external/cwrap.m4])
if test x$build_config_lib = xyes; then
m4_include([src/external/libaugeas.m4])
@@ -323,6 +324,8 @@ AM_CONDITIONAL([HAVE_DOXYGEN], [test x$DOXYGEN != xfalse ])
AM_CONDITIONAL([HAVE_CHECK], [test x$have_check != x])
AM_CHECK_CMOCKA
+AM_CHECK_UID_WRAPPER
+AM_CHECK_NSS_WRAPPER
AM_CONDITIONAL([HAVE_DEVSHM], [test -d /dev/shm])